building a transparent bridge on OpenBSD
by bram
- get three network cards, two for the bridge, mine are re0, em0 & em1 (re0 = admin connection to serve sshd)
- echo ‘dhcp’ > /etc/hostname.re0
- echo ‘up’ > /etc/hostname.em0
- echo ‘up’ > /etc/hostname.em1
- echo ‘add em0’ > /etc/hostname.bridge0
- echo ‘add em1’ >> /etc/hostname.bridge0
- echo ‘blocknonip em0’ >> /etc/hostname.bridge0
- echo ‘blocknonip em1’ >> /etc/hostname.bridge0
- echo ‘up’ >> /etc/hostname.bridge0
- vi /etc/sysctl.conf
=> uncomment “#net.inet.ip.forwarding=1”
Published on December 22, 2010
in howto, unix/linux/bsd